Feature #10015

Add support for bulk/large export of repository records via the clipboard, using the job scheduler

Added by Dan Gillean about 4 years ago. Updated almost 3 years ago.

Status:VerifiedStart date:06/13/2016
Priority:MediumDue date:
Assignee:-% Done:

0%

Category:RepositoryEstimated time:24.00 hours
Target version:Release 2.4.0
Google Code Legacy ID: Tested version:
Sponsored:Yes Requires documentation:

Description

This feature extends the work described in #9998 and related tickets to repository records (by leveraging the work in #8591), and builds upon the clipboard user interface work described in #10011

Users will be able to export repository record data in CSV format from the clipboard.

export-config.png (60.2 KB) Sara Allain, 06/20/2017 08:47 PM


Related issues

Related to Access to Memory (AtoM) - Feature #8591: Create an export:repositories task Verified 06/22/2015

History

#2 Updated by Dan Gillean about 4 years ago

  • Related to Feature #8591: Create an export:repositories task added

#5 Updated by Dan Gillean almost 4 years ago

  • Target version changed from Release 2.4.0 to Release 2.5.0

#6 Updated by Dan Gillean over 3 years ago

  • Target version changed from Release 2.5.0 to Release 2.4.0

#7 Updated by Dan Gillean about 3 years ago

  • Status changed from New to QA/Review

#8 Updated by Sara Allain about 3 years ago

  • Assignee set to Sara Allain

#9 Updated by Sara Allain about 3 years ago

This is not working as expected, though I feel like it did in the past. Tested this on my 2.4.x VM, after running vagrant-box-update to update to 2.4.0.1, and on http://atomqa24x.accesstomemory.org.

Lower levels of description are not being exported unless their parent is also exported. I added a collection that includes Series- and Item-level records to the clipboard and then limited the export to only those lower levels of description (see export-config.png). This resulted in no relevant archival descriptions being found.

[info] [2017-06-20 17:17:16] Job 2765 "CSV export": Job started.
[info] [2017-06-20 17:17:16] Job 2765 "CSV export": Starting export to /tmp/search_export_2765.
[info] [2017-06-20 17:17:16] Job 2765 "CSV export": Exported 0 descriptions.
[info] [2017-06-20 17:17:16] Job 2765 "CSV export": No relevant archival descriptions were found to export.
[info] [2017-06-20 17:17:16] Job 2765 "CSV export": Job finished.

Essentially, because I didn't select Collection or Fonds to be exported, a child record of that fonds is ALSO not being exported. I can see this being a problem - archivists might want to be able to export all items in a fonds, but not necessarily the fonds-level record.

In summary: in order to export a child record, you must also export its direct parent. So if you have a collection in this format:

- Fonds
-- Series 1
--- Item
--- Item
--- Item
-- Series 2
--- Item
--- Item
--- Item

you have to export the fonds and series records in order to export the item. You can't bypass the series and only export the fonds and items.

#10 Updated by Dan Gillean about 3 years ago

  • Assignee changed from Mike Gale to Sara Allain

Hi Sara,

First, this ticket is in relation to the export of repository records. I think this comment might be better suited to issue #10000?

Second, note in your screenshot the help text found below the level selector:

"Descriptions that are descendants of levels not included in the export will also be excluded."

We did this because it's not easily possible to generate valid EAD XML that excludes the parent but includes the children - AtoM would essentially have to recreate a new hierarchy on the fly by temporarily reassigning child records to the next available parent, so the EAD didn't come out broken. For consistency and simplicity, we made the CSV export behave the same way, figuring it was easy enough for users to delete parent rows from a CSV if desired.

If you feel like we should revisit that, let's discuss further?

#11 Updated by Sara Allain about 3 years ago

Whoops, got lost in the tickets. Apologies. Copied the comments to the proper ticket so that it's preserved where it should be.

If that's the expected behaviour, that's fine. At least it's described for documentation.

#12 Updated by Sara Allain about 3 years ago

  • Status changed from QA/Review to Document

Tried with 504 repository records, and it worked well!

#13 Updated by Dan Gillean about 3 years ago

  • Status changed from Document to Verified
  • Assignee deleted (Sara Allain)

Awesome! Marking verified - we don't need to use the "Document" status as we're tracking documentation needs via the "Requires documentation" element, allowing us to verify issues that will be included in the release :)

#14 Updated by Dan Gillean almost 3 years ago

  • Requires documentation deleted (Yes)

Also available in: Atom PDF