Bug #10287

arMetsToDatabaseTask::run() signature not correct

Added by Mike Gale almost 4 years ago. Updated almost 4 years ago.

Status:VerifiedStart date:09/08/2016
Priority:MediumDue date:
Assignee:José Raddaoui Marín% Done:

0%

Category:CLI tools
Target version:Release 2.4.0
Google Code Legacy ID: Tested version:
Sponsored:No Requires documentation:

Description

I keep getting this if I run tools:upgrade:

PHP Strict standards: Declaration of arMetsToDatabaseTask::run() should be compatible with sfTask::run($arguments = Array, $options = Array) in /home/mikeg/workspace/atom/lib/task/tools/arMetsToDatabaseTask.class.php on line 171

History

#1 Updated by José Raddaoui Marín almost 4 years ago

  • Status changed from New to QA/Review
  • Assignee changed from José Raddaoui Marín to Mike Gale
  • Target version set to Release 2.4.0

Hi Mike, I can't see that in my local instance, but PR 433 should fix it. Please, give it a try and feel free to merge the commit if it works.

#2 Updated by Jesús García Crespo almost 4 years ago

You guys are probably using different environments, e.g. see error_reporting(), E_ALL, E_STRICT, etc... one more reason to switch to our Vagrant box! It's been out for more than three years, just saying :)

#3 Updated by Mike Gale almost 4 years ago

  • Assignee changed from Mike Gale to José Raddaoui Marín

looks good

#4 Updated by José Raddaoui Marín almost 4 years ago

  • Status changed from QA/Review to Verified

Also available in: Atom PDF