Bug #10336

Message not displaying correctly when taxonomy edited

Added by Joel Dunham over 5 years ago. Updated about 5 years ago.

Status:QA/ReviewStart date:09/21/2016
Priority:LowDue date:
Assignee:Sarah Romkey% Done:

90%

Category:Dashboard
Target version:Release 1.7.0
Google Code Legacy ID: Pull Request:https://github.com/artefactual/archivematica/pull/499
Sponsored:No Requires documentation:

Description

When a user edits a taxonomy, instead of saying "Saved." using Django's messaging system, a literal Python dict is displayed in the HTML, i.e., {'text': 'Saved.'} PR#499 (https://github.com/artefactual/archivematica/pull/499) fixes this.

History

#1 Updated by Sarah Romkey over 5 years ago

  • Status changed from QA/Review to Feedback
  • Assignee changed from Sarah Romkey to Joel Dunham
  • Priority changed from Medium to Low
  • Target version changed from Release 1.6 to Release 1.7.0

Hi Joel, I'm still seeing the Python dict. Bumping this to the next release so we can focus on more critical bugs.

#2 Updated by Joel Dunham over 5 years ago

Hi Sarah,

I tested this with the AM dev/issue-xxxx-fix-taxonomy-message-bug branch and I edited some terms at http://192.168.168.192/administration/taxonomy/term/ and when I clicked the "Save". AM correctly displays "Saved." in a nice blue box in my testing. If you're still seeing the raw dict, can you give me more details about what you are doing? Thanks

#3 Updated by Joel Dunham over 5 years ago

  • Assignee changed from Joel Dunham to Sarah Romkey

#4 Updated by Jesús García Crespo about 5 years ago

  • Status changed from Feedback to QA/Review

I've recently merged this into qa/1.x and it seems to work fine: http://imgur.com/Oj4fcfk.

Also available in: Atom PDF