Feature #13537

Update PHP Coding Standards Fixer (PHP-CS-Fixer) configuration for v3 compatibility

Added by David Juhasz 3 months ago. Updated 2 months ago.

Status:QA/ReviewStart date:06/28/2021
Priority:MediumDue date:
Assignee:-% Done:

0%

Category:Continuous Integration
Target version:Release 2.7.0
Google Code Legacy ID: Tested version:2.7
Sponsored:No Requires documentation:No

Description

PHP Coding Standards Fixer (PHP-CS-Fixer) version 3 (Constitution) was released 3 May 2021 and requires several changes to the AtoM configuration for compatibility with the new version. See: UPGRADE GUIDE FROM 2.x to 3.0 for a list of changes required by the upgrade.

History

#1 Updated by David Juhasz 2 months ago

  • Status changed from New to QA/Review
  • Requires documentation set to No

#2 Updated by David Juhasz 2 months ago

  • Subject changed from Update PHP Coding Standards Fixer (PHP-CS-Fixer) configuration file name for v3 compatibility to Update PHP Coding Standards Fixer (PHP-CS-Fixer) configuration for v3 compatibility
  • Description updated (diff)

Update ticket description and summary to reflect this is a general php-cs-fixer v3 upgrade.

Also available in: Atom PDF