Bug #4117

Migrated information objects showing up twice in browse list

Added by David Juhasz almost 10 years ago. Updated over 8 years ago.

Status:VerifiedStart date:
Priority:CriticalDue date:
Assignee:Jesús García Crespo% Done:

0%

Category:Migration task
Target version:Release 1.3.1
Google Code Legacy ID:atom-2169 Tested version:
Sponsored:No Requires documentation:

Description

To reproduce this error:
1)Migrate data from early release of Qubit
2)Browse information objects

Resulting error:
Each top level object shows up twice.

Expected result:
Only one instance per object

[g] Legacy categories: Migration task

History

#1 Updated by David Juhasz almost 10 years ago

Each object is getting assigned TWO publication status rows. :(

#2 Updated by David Juhasz almost 10 years ago

I think this is due to r10202

#3 Updated by David Juhasz almost 10 years ago

  • Status changed from New to Verified

Fixed in r10310.

#4 Updated by David Juhasz almost 10 years ago

  • Status changed from Verified to Verified

Update status to verified.

#5 Updated by David Juhasz over 9 years ago

[g] New owner: David Juhasz

#6 Updated by Redmine Admin almost 9 years ago

  • Category set to Migration task

#7 Updated by David Juhasz almost 9 years ago

  • Status changed from Verified to QA/Review
  • Target version changed from Release 1.2 to Release 1.4.0
  • Sponsored set to No

Re-opened because I've re-added this change to the current codebase (https://github.com/artefactual/atom/commit/d3137e77c5407c067bc79ff45ce1c6fafffb454d), since the migration problem should no longer be a problem. We need to test this with the current upgrader script just to double-check though.

#8 Updated by Jessica Bushey almost 9 years ago

David - who is testing this? If you'd like me to test it, could you explain the steps?

#9 Updated by David Juhasz almost 9 years ago

Jessica - I'll work on getting you a legacy data set and a set of instructions for testing the upgrade script. It may take me a while... :(

#10 Updated by Dan Gillean over 8 years ago

  • Description updated (diff)

#11 Updated by Jessica Bushey over 8 years ago

The last comment was made by Dan - but the status is still Q/A Review. Should it be feedback?

On Wednesday we migrated MemoryBC test data and updated it from 1.2 - 1.3 AtoM in my VM and in Dan's VM.
I did not get any duplication of the top level objects.
I think Dan was unable to upgrade his VM - Jesus was working on it, last I knew.

#12 Updated by Jessica Bushey over 8 years ago

  • Assignee changed from David Juhasz to Jesús García Crespo

#13 Updated by Dan Gillean over 8 years ago

I had VM issues and was unable to test this issue. My last comment was merely a clean-up of the issue description, removing some of the strange formatting that appeared as a result of the migration from Google Code hosting to Redmine.

#14 Updated by Jessica Bushey over 8 years ago

  • Status changed from QA/Review to Verified

I migrated MemoryBC data from 1.2 - 1.X AtoM.
Reviewed "browse" page for information objects. Everything singular.

#15 Updated by David Juhasz over 8 years ago

  • Target version changed from Release 1.4.0 to Release 1.3.1

Also available in: Atom PDF