Feature #4183

Default sort order setting (Alphabetic or Last Updated) should be Admin Configurable

Added by Anonymous over 8 years ago. Updated over 7 years ago.

Status:VerifiedStart date:
Priority:HighDue date:
Assignee:David Juhasz% Done:

0%

Category:-
Target version:Release 1.3
Google Code Legacy ID:atom-2235 Tested version:
Sponsored: Requires documentation:

Description

Google user: jessica%...@gtempaccount.com

Patch requested by CVA to make default sort order setting configurable by the institutional Administrator.

[g] Legacy categories: Search / browse, Menu / navigation

History

#1 Updated by Anonymous over 8 years ago

[g] Labels added: Type-Enhancement
[g] Labels removed: Type-Patch

#2 Updated by Anonymous over 8 years ago

  • Target version changed from Release 1.2.1 to Release 1.3

Wu made a patch for this feature but it is complicated and could take over 4 hours.

[g] Labels added: Milestone-Release-1.3
[g] Labels removed: Milestone-Release-1.2.1
[g] New owner: Jesús García Crespo

#4 Updated by Jesús García Crespo over 8 years ago

See also /p/qubit-toolkit/issues/detail?id=1932

#5 Updated by Jesús García Crespo over 8 years ago

  • Status changed from New to Verified

Fixed in r11008.

#6 Updated by Jesús García Crespo over 8 years ago

Default settings: lastUpdated for users, alphabetic for anonymous

#7 Updated by Anonymous over 8 years ago

  • Status changed from Verified to Verified

Great!
Admin -> Global -> public and user settings

#8 Updated by David Juhasz over 8 years ago

  • Status changed from Verified to In progress

Bug report from Glenn @ CVA:

"Browse Information Objects defaults to the Alphabetical tab, but the results are not in alpha order. You have to click the tab to make them sort properly"

[g] New owner: David Juhasz

#9 Updated by Jesús García Crespo over 8 years ago

  • Status changed from In progress to Verified

This fix requires a db upgrade, that could be the reason.

#10 Updated by David Juhasz over 8 years ago

Confirmed, adding the correct settings to the database fixed the error in comment #8.

#11 Updated by Anonymous over 8 years ago

  • Status changed from Verified to Verified

alphabetic default selected.
alphabetic sort in browse works.

#12 Updated by David Juhasz about 8 years ago

[g] New owner: David Juhasz

Also available in: Atom PDF