Bug #4193

Advanced search - search by name access points incomplete

Added by Tim Hutchinson over 8 years ago. Updated over 7 years ago.

Status:Won't fixStart date:
Priority:HighDue date:
Assignee:Jesús García Crespo% Done:

0%

Category:-
Target version:Release 1.3
Google Code Legacy ID:atom-2245 Tested version:
Sponsored: Requires documentation:

Description

To reproduce this error: ========================
1) On the demo site, go to the advanced search
2) Search for "vancouver" and limit to "name access points"

Resulting error: ================
No results are returned

Expected result: ================
Vancouver City Clerk fonds should be a matching entry.

It looks like only name access points entered as subjects are indexed; if the names are entered through the event dialog (creators, collectors, etc.), they are not. (I also switched to the RAD template and entered a collector access point; this was also not returned through the advanced search.)

The same thing occurs using the advanced search syntax name:vancouver.

So, a change to the indexing as of 1.2? This does not seem to occur in the SAIN implementation (1.1) of the advanced search.

[g] Legacy categories: Search / browse

History

#1 Updated by Jesús García Crespo over 8 years ago

  • Priority set to High
  • Target version set to Release 1.2.1

Thank you so much for your report and invaluable help, Tim.

[g] Labels added: Milestone-Release-1.2.1, Priority-High, Component-SearchBrowse
[g] New owner: MJ Suhonos

#2 Updated by David Juhasz over 8 years ago

  • Status changed from New to Verified

Fixed in r10947.

Requires a rebuilding the search index.

[g] New owner: David Juhasz

#3 Updated by David Juhasz over 8 years ago

  • Status changed from Verified to In progress

The search is not returning hits on ANY name access points now (r11431).

#4 Updated by David Juhasz over 8 years ago

  • Status changed from In progress to QA/Review

Fixed in r11432. Requires search index rebuild.

[g] New owner:

#5 Updated by Anonymous over 8 years ago

  • Status changed from QA/Review to Feedback

It's sorta working... I get a white screen. So... I'm getting this warning when I run it in dev mode.

Notice: session_start() [function.session-start]: ps_files_cleanup_dir: opendir(/var/lib/php5) failed: Permission denied (13) in /var/www/qubit/vendor/symfony/lib/storage/sfSessionStorage.class.php on line 92

Warning: Invalid argument supplied for foreach() in /var/www/qubit/apps/qubit/modules/event/actions/editComponent.class.php on line 114

Notice: Undefined variable: value in /var/www/qubit/apps/qubit/modules/event/actions/editComponent.class.php on line 122

Warning: Invalid argument supplied for foreach() in /var/www/qubit/apps/qubit/modules/right/actions/editComponent.class.php on line 188

Notice: Undefined property: sfRoute::$resource in /var/www/qubit/apps/qubit/modules/informationobject/actions/editAction.class.php on line 349

Notice: Trying to get property of non-object in /var/www/qubit/apps/qubit/modules/informationobject/actions/editAction.class.php on line 350

Notice: Trying to get property of non-object in /var/www/qubit/apps/qubit/modules/informationobject/actions/editAction.class.php on line 350

Notice: Undefined property: sfRoute::$resource in /var/www/qubit/apps/qubit/modules/informationobject/actions/editAction.class.php on line 349

Notice: Trying to get property of non-object in /var/www/qubit/apps/qubit/modules/informationobject/actions/editAction.class.php on line 350

Notice: Trying to get property of non-object in /var/www/qubit/apps/qubit/modules/informationobject/actions/editAction.class.php on line 350

Fatal error: Call to a member function __get() on a non-object in /var/www/qubit/lib/model/om/BaseObject.php on line 456

#6 Updated by Anonymous over 8 years ago

When I test this error on the ICA-AtoM demo site I can replicate the problem.
When I test this in trunk, it works. No error.

#7 Updated by Tim Hutchinson over 8 years ago

Maybe the demo site needs to be re-indexed? I'm not sure what's involved in the re-build process.

#8 Updated by David Juhasz over 8 years ago

  • Target version changed from Release 1.2.1 to Release 1.3

Sorry, I missed the fact that this issue report was specific to the demo site.

The name access search problem described was a general issue with ICA-AtoM Release 1.2 that has been fixed in the development trunk (r11432). Since the demo site is running Release 1.2 (with some patches) the fix is not relevant.

The problem will be fixed once we upgrade the demo site to Release 1.3, when it is released.

[g] Labels added: Milestone-Release-1.3
[g] Labels removed: Milestone-Release-1.2.1

#9 Updated by Jessica Bushey about 8 years ago

[g] New owner: Jessica Bushey

#10 Updated by Jesús García Crespo about 8 years ago

[g] New owner: Jesús García Crespo

#11 Updated by David Juhasz about 8 years ago

  • Status changed from Feedback to Won't fix

Also available in: Atom PDF