Bug #4328

PDF thumbnails creation with a black background

Added by Jesús García Crespo about 8 years ago. Updated over 7 years ago.

Status:VerifiedStart date:
Priority:HighDue date:
Assignee:Jesús García Crespo% Done:

0%

Category:-
Target version:Release 1.3
Google Code Legacy ID:atom-2380 Tested version:
Sponsored: Requires documentation:

Description

This problem was detected after upgrading to Ubuntu 12.04, it's likely that new releases included in 12.04 have this issue.

See also:
http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=20234

[g] Legacy categories: Digital object


Related issues

Related to Access to Memory (AtoM) - Bug #9980: PDF derivatives not generating properly Invalid 06/10/2016
Duplicated by Access to Memory (AtoM) - Bug #4326: Uploaded pdfs showing black in thumbnail and reference di... Duplicate

History

#1 Updated by Jesús García Crespo about 8 years ago

  • Status changed from New to QA/Review

Fixed in r11926 and r11927.

Hint for QA: test against multiple different PDF files, also test PDF files including images, etc. This is an issue related to the transparency found in PDF layers. The fix seems to work there might be a negative impact in others. The problem is in converting PDF alpha layers to JPEG, which does not support transparency. Therefore, we may need to consider PNG for that. I'm not an expert on digital formats.

Before the fix:
$ convert -thumbnail 370x480 -quality 75% 'example.pdf'['0'] thumbnail.jpg

After the fix:
$ convert -thumbnail 370x480 -quality 75% -background white -flatten 'example.pdf'['0'] thumbnail.jpg

#2 Updated by Jessica Bushey about 8 years ago

Could you clarify the steps for QA review?
Are we importing PDFs into ICA-AtoM and checking to see if the thumbnails are created with a black background?

#3 Updated by Jessica Bushey about 8 years ago

  • Status changed from QA/Review to Feedback

Testing in ICA-Atom:

In what view window should I see the black background?
There is a black outline for each thumbnail in the browse digital object screen.
There is no black outline for the representation in the view archival description screen.
There is no black outline in the cover flow viewer.
There is no black outline in the edit digital object screen.

#4 Updated by Jesús García Crespo about 8 years ago

  • Status changed from Feedback to QA/Review

I think this should be tested by Evelyn or Courtney since they are using Ubuntu 12.04. Your testing VM is running Ubuntu 10.04. Evelyn knows what is the problem, she reported it although I filed the issue.

Please see the link shared in this issue for an example:
http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=20234#p80236

#6 Updated by Evelyn McLellan about 8 years ago

  • Status changed from QA/Review to Verified

#7 Updated by Sara Allain about 4 years ago

  • Related to Bug #9980: PDF derivatives not generating properly added

Also available in: Atom PDF