Bug #4365

Treeview: first click on "arrow" doesn't show child levels

Added by David Juhasz almost 8 years ago. Updated over 7 years ago.

Status:VerifiedStart date:
Priority:CriticalDue date:
Assignee:Jesús García Crespo% Done:

0%

Category:-
Target version:Release 1.3
Google Code Legacy ID:atom-2417 Tested version:
Sponsored: Requires documentation:

Description

To reproduce this error: ========================
1)Create a Fonds with child levels
2)View the fonds level description
3)Click the arrow beside the Fonds in the treeview
4)Spinner spins for a second, but when it stops the treeview is unchanged

Resulting error: ================

(See screenshot)

GET http://127.0.0.1/qubit/index.php/example-fonds;informationobject/treeView?show=item&resourceId=313
f.support.ajax.f.ajaxTransport.sendjquery.js:4
f.extend.ajaxjquery.js:4
Treeview.showItemtreeView.js:431
Treeview.clicktreeView.js:388
e.extend.proxy.gjquery.js:2
f.event.dispatchjquery.js:3
f.event.add.h.handle.i

Expected result: ================
Treeview displays children of Fonds

[g] Legacy categories: Hierarchy

Screenshot at 2012-08-22 13_42_18.png (196 KB) David Juhasz, 12/01/2012 05:40 AM

treeview_ellipses_after_2_clicks.PNG (12.1 KB) David Juhasz, 12/01/2012 05:40 AM

denis-landry-2;ead.xml Magnifier (26.5 KB) Jessica Bushey, 12/01/2012 05:41 AM

Tree-GrowEllipses.png (10.5 KB) Jessica Bushey, 12/01/2012 05:41 AM

Tree-GrowEllipses2.png (10.7 KB) Jessica Bushey, 12/01/2012 05:41 AM

History

#1 Updated by David Juhasz almost 8 years ago

This is also true of ellipses at the bottom of treeview - clicking on them often (but not always) causes them to extend but not actually open and populate the list with further results as expected. Often it takes several of these clicks/expansions to finally load the results.

See attached screenshot, where the ellipses has expanded lengthwise without providing further results after being clicked.

#2 Updated by Jesús García Crespo almost 8 years ago

  • Status changed from New to QA/Review

Could you provide some sample data to reproduce this issue, Dan?

#3 Updated by Jessica Bushey almost 8 years ago

I tested in Trillium with the treeview sort order set to manual and also experienced the arrow not opening on the first click AND the ellipses not expanding the treeview on the first click.

I tested using the Denis Landry Fonds, see attached.

#4 Updated by Jessica Bushey almost 8 years ago

I tested with the treeview sort order set to identifier and didn't get any problems.

I tested with the treeview sort order set to title and had problems.
1) Browse information objects and select one from the list
2) In the view information object screen select the arrow of a different fonds (NOT the one that is highlighted)

resulting error:

clicking on arrow does not produce a response. you must click a second time and then the fonds opens in the treeview.

expected result:

clicking on arrow of any fonds in the treeview (highlighted or not) the fonds opens to reveal lower child-levels.

#5 Updated by Jessica Bushey almost 8 years ago

I tested what happens when I click on ellipses, and instead of seeing more child-levels the ellipses grow. See attached shots titled Tree-GrowEllipses and Tree-GrowEllipses2

#6 Updated by Jesús García Crespo almost 8 years ago

  • Status changed from Feedback to QA/Review

Mm that's weird, I can't reproduce.

#7 Updated by Jesús García Crespo almost 8 years ago

I will keep trying.

#8 Updated by Jesús García Crespo almost 8 years ago

r12189 could be a fix

#9 Updated by Jessica Bushey almost 8 years ago

  • Status changed from QA/Review to Verified

Everything seems to be working now.
I tested in different themes.
The arrows are opening on first click.
The ellipses are opening on click.

Also available in: Atom PDF