Bug #4713

Deleted record still shows in search results, causes 404 error

Added by Justin Simpson over 6 years ago. Updated over 6 years ago.

Status:VerifiedStart date:02/20/2013
Priority:HighDue date:
Assignee:Jesús García Crespo% Done:

0%

Category:Search / Browse
Target version:Release 1.3.1
Google Code Legacy ID: Tested version:
Sponsored:No Requires documentation:

Description

I reproduced this issue on the demo.ica-atom.org site.

steps:
1) log in as /demo.
2) do a basic search on the term 'parking', which should return 1 result.
3) go to that page, and delete it.
4) do the same search again. Note that 1 result is still returned.

You will see the page that you just deleted returned in the search results. If you click on it, you get a 'sorry, page not found' message.

When a page is deleted, it should also be removed from the search results, i.e., in step 4, there should be zero results returned.


Related issues

Related to Access to Memory (AtoM) - Bug #4157: Server 500 error on multiple record deletion Verified
Related to Access to Memory (AtoM) - Task #5946: Duplicate record for archival description in the search i... Verified 10/30/2013

History

#1 Updated by Jesús García Crespo over 6 years ago

  • Priority changed from Medium to High

#2 Updated by Jesús García Crespo over 6 years ago

Radda, please take a look at this issue when you have a chance! I bumped it to High.

#3 Updated by Jesús García Crespo over 6 years ago

  • Assignee changed from José Raddaoui Marín to Jesús García Crespo

#4 Updated by Jesús García Crespo over 6 years ago

  • Status changed from New to QA/Review

Fixed in commit:c0f3b6dd23af.

#5 Updated by Sylvia Stopforth over 6 years ago

Thanks for the update, Jesus.
(Sylvia, #4713 is fixed now in our development tree. Justin is planning to upgrade your site as soon as possible.)

I take it this item was not addressed with the nightly rebuild of the search index ... ?
Sylvia

#6 Updated by David Juhasz over 6 years ago

  • Target version changed from Release 1.4.0 to Release 1.3.1

#7 Updated by David Juhasz over 6 years ago

Hi Sylvia,

The nightly rebuild of the search index was a work-around until we could find and fix the underlying bug in the ICA-AtoM code. Once this fix is applied to your server, you should no longer need the nightly rebuild. :)

Cheers,
David

Sylvia Stopforth wrote:

Thanks for the update, Jesus.
(Sylvia, #4713 is fixed now in our development tree. Justin is planning to upgrade your site as soon as possible.)

I take it this item was not addressed with the nightly rebuild of the search index ... ?
Sylvia

#8 Updated by Jessica Bushey over 6 years ago

  • Status changed from QA/Review to Verified

1. create description with access points and save
2. search on those access points and get result
3. delete result
4. perform search again on access point
5. no results found

FIXED!

Also available in: Atom PDF