Bug #584

Wrong number of Information Objects added during rebuild of search index

Added by David Juhasz almost 9 years ago. Updated over 8 years ago.

Status:VerifiedStart date:10/11/2012
Priority:CriticalDue date:
Assignee:David Juhasz% Done:

100%

Category:Search / BrowseEstimated time:8.00 hours
Target version:Release 1.3.1
Google Code Legacy ID: Tested version:
Sponsored:No Requires documentation:

issue584.patch Magnifier (26.2 KB) David Juhasz, 10/28/2012 03:25 PM


Related issues

Duplicated by Access to Memory (AtoM) - Bug #4375: Wrong number of Information Objects itens during rebuild ... Verified

History

#2 Updated by David Juhasz almost 9 years ago

  • Status changed from New to QA/Review

#3 Updated by Jessica Bushey almost 9 years ago

David - how am I supposed to test this?

#4 Updated by David Juhasz almost 9 years ago

To test:

  1. Create at least two descriptions, and one with multiple languages (I import a regular English EAD file, then create a simple multi-lingual description)
  2. Rebuild search index <https://www.qubit-toolkit.org/wiki/Rebuild_search_index>
  3. In search index output, make sure the counter does not show more results than the total number of documents e.g.
    sfSearch >> QubitInformationObject - In English inserted (0.81s) (16/14)
  4. Test that all search fields <https://www.ica-atom.org/doc/Search_fields> return expected results
  5. Test that multiple instances of the same description are not returned in search results

#5 Updated by David Juhasz almost 9 years ago

  • Subject changed from Wrong number of Information Objects itens during rebuild of search index to Wrong number of Information Objects adding during rebuild of search index

#6 Updated by David Juhasz almost 9 years ago

  • Subject changed from Wrong number of Information Objects adding during rebuild of search index to Wrong number of Information Objects added during rebuild of search index

#7 Updated by David Juhasz almost 9 years ago

  • Status changed from QA/Review to Feedback

Mike found some bugs with the script.

#8 Updated by David Juhasz almost 9 years ago

Events are not working properly (creator, bio/admin history, dates)

#9 Updated by Jessica Bushey almost 9 years ago

I will wait until status is back to QA Review before testing.

#10 Updated by David Juhasz almost 9 years ago

  • Status changed from Feedback to QA/Review

Events are working. I think everything should be working properly again.

#11 Updated by David Juhasz almost 9 years ago

Attach patch file.

#12 Updated by Jessica Bushey almost 9 years ago

  • Status changed from QA/Review to Verified

Search index is accurate.
Search fields are behaving as expected.
Subject terms that are translated are viewable in the browse subject terms page and in the archival description view page. I have updated Issue 1505: http://code.google.com/p/qubit-toolkit/issues/detail?id=1505 with this incorrect behaviour.

#13 Updated by David Juhasz over 8 years ago

  • Target version changed from Release 1.4.0 to Release 1.3.1
  • Sponsored set to No

Also available in: Atom PDF