Bug #7965

DIP upload gets into infinite loop in AtoM, adding new packages continuously

Added by Dan Gillean over 7 years ago. Updated over 7 years ago.

Status:VerifiedStart date:02/11/2015
Priority:HighDue date:
Assignee:Dan Gillean% Done:

100%

Category:Archivematica integration
Target version:Release 2.1.2
Google Code Legacy ID: Tested version:2.1, 2.1.1
Sponsored:No Requires documentation:

Description

This is an edge case that requires specific conditions to reproduce, where the maxbytelength is exceeded for a DIP being written to the search index, which then crashes Elasticsearch. Because the DIP upload has failed, Archivematica will try the upload again and again, creating thousands of objects/descriptions.

The error message before the cycle repeats
PHP Fatal error: Uncaught exception 'Elastica\Exception\Bulk\ResponseException' with message 'Error in one or more bulk request actions:`

History

#2 Updated by Dan Gillean over 7 years ago

  • Status changed from New to Verified

Fixed in 2.1.2 release.

Also available in: Atom PDF