Bug #8032

Edit template broken in RAD template

Added by Dan Gillean about 7 years ago. Updated about 7 years ago.

Status:VerifiedStart date:02/26/2015
Priority:CriticalDue date:
Assignee:Dan Gillean% Done:

0%

Category:Information object
Target version:Release 2.2.0
Google Code Legacy ID: Tested version:2.2
Sponsored:No Requires documentation:

Description

To reproduce
  • Create a description, save
  • Switch to RAD template
  • Attempt to edit

Resulting error
Edit template page loads without any CSS or Javascript; is unusable and cannot be saved.

Expected result
Edit template works as expected.

Notes
David J thinks that this is an overlooked side-effect of the HTML escaping work carried out as a part of #7699. He thinks it originates with this commit: https://github.com/artefactual/atom/blame/qa/2.2.x/plugins/sfRadPlugin/modules/sfRadPlugin/templates/editSuccess.php#L413

It may have been missed in the original testing period as it is particular to the RAD template. When QAing this issue, all templates should be checked.

Marking critical because this is basic functionality that must be fixed before the 2.2 release. Assigning to David J for triage.

History

#2 Updated by José Raddaoui Marín about 7 years ago

  • Status changed from New to QA/Review
  • Assignee changed from David Juhasz to Dan Gillean

#3 Updated by Sarah Romkey about 7 years ago

  • Status changed from QA/Review to Verified

Fixed! I checked all the templates just to be sure.

Also available in: Atom PDF