Bug #8554

Publication date not filled in properly when exporting EAD from CLI

Added by Mike Gale almost 7 years ago. Updated almost 7 years ago.

Status:VerifiedStart date:06/11/2015
Priority:MediumDue date:
Assignee:Dan Gillean% Done:

0%

Category:EAD
Target version:Release 2.2.0
Google Code Legacy ID: Tested version:2.2, 2.3
Sponsored:No Requires documentation:

Description

The publicationstmt's date field isn't filled out properly when exporting EAD from the CLI. It works when exporting from UI, however.

0001-Fix-publication-date-in-EAD-CLI-export-8554.patch Magnifier (2.97 KB) Mike Gale, 06/11/2015 07:47 PM

History

#1 Updated by Mike Gale almost 7 years ago

#2 Updated by Mike Gale almost 7 years ago

Note: I think sometime in the future we should work on moving code like this: https://github.com/artefactual/atom/blob/qa/2.2.x/plugins/sfEadPlugin/modules/sfEadPlugin/actions/indexAction.class.php#L45-L52

To a common area like EAD plugin too. Because that code is duplicated in the CLI task as well. Having 2 different spots to initialize variables the EAD export needs created this bug in the first place.

#3 Updated by José Raddaoui Marín almost 7 years ago

  • Status changed from Code Review to In progress
  • Assignee changed from José Raddaoui Marín to Mike Gale

Looks good!

#4 Updated by Mike Gale almost 7 years ago

  • Status changed from In progress to QA/Review
  • Assignee changed from Mike Gale to Dan Gillean

merged qa/2.2.x (2edf7d2a70e285df90f9a5e5530cc0b8dc7e69e9)

#5 Updated by Dan Gillean almost 7 years ago

  • Status changed from QA/Review to Verified

Also available in: Atom PDF