Bug #8960

Generate slug via title or ref code setting does not work

Added by Mike Gale over 6 years ago. Updated over 6 years ago.

Status:VerifiedStart date:09/14/2015
Priority:MediumDue date:
Assignee:Dan Gillean% Done:

0%

Category:Information object
Target version:Release 2.3.0
Google Code Legacy ID: Tested version:
Sponsored:No Requires documentation:

Description

The switch statement here no longer seems to work for me: https://github.com/artefactual/atom/blob/qa/2.3.x/lib/model/QubitInformationObject.php#L2896

So it tries to generate from reference code every time regardless of the setting. I have no idea how this worked before, but the fix is easy. We just need to call getValue() instead of relying on the (int) typecast.

slug_gen_fix.patch Magnifier (850 Bytes) Mike Gale, 09/14/2015 04:50 PM


Related issues

Related to Access to Memory (AtoM) - Feature #8781: Create a setting that lets the user set whether or not to... Verified 08/05/2015

History

#1 Updated by Mike Gale over 6 years ago

  • Related to Feature #8781: Create a setting that lets the user set whether or not to use reference code or title as the basis for archival description slugs added

#3 Updated by Mike Gale over 6 years ago

  • File slug_gen_fix.patchMagnifier added
  • Status changed from New to Code Review
  • Assignee changed from Mike Gale to Jesús García Crespo

#4 Updated by Mike Gale over 6 years ago

  • Status changed from Code Review to QA/Review
  • Assignee changed from Jesús García Crespo to Dan Gillean

merged qa/2.3.x

#5 Updated by Dan Gillean over 6 years ago

  • Category set to Information object
  • Status changed from QA/Review to Verified

Note that the original feature, as described in #8781, is still under discussion and may undergo change - however, this is separate from this bug report. Considered verified.

Also available in: Atom PDF