Feature #944

"Browse directory" feature

Added by Evelyn McLellan almost 11 years ago. Updated almost 9 years ago.

Status:VerifiedStart date:
Priority:CriticalDue date:
Assignee:Jesús García Crespo% Done:

0%

Category:-
Target version:Release 0.7
Google Code Legacy ID:archivematica-289 Pull Request:
Sponsored: Requires documentation:

Description

To reproduce this error: ========================
In dashboard, click "Open directory" for SIP requiring approval of a task

Resulting error: ================
Nothing happens - directory doesn't open

Expected result: ================
Should open directory

[g] Legacy categories: Dashboard


Related issues

Duplicated by Archivematica - Feature #844: Add links to dashboard for SIP folder path awaiting appro... Duplicate

History

#1 Updated by Peter Van Garderen almost 11 years ago

We need a browser-independent way to implement this feature (i.e. not reliant on FF plugin). Ideally it will be able to open in another tab so that the user doesn't loose the Dashboard view.

It can be fairly simple, i.e. the Apache index page feature will do. Another possibility is to use a Python library for listing and displaying files via a Django template. I prefer this latter approach because I see us enhancing the view we provide on the file directories to include things like graphs and other data visualizations (i.e. a bar graph indicating the relative size on disk for a list of directories, a bar graph providing a breakdown/count of the file formats in that directory, see http://vis.stanford.edu/protovis/). Also, integration of full-text index that have already been run on the directory, we then display faceted results for pre-determined keywords (i.e. 'classified' 'private') on the same directory page. In other words, the 'Open Directory' function will lead to a tab that allows users to review the files but also incorporates tools that allows them to evaluate and appraise the large lists of files that it is likely to link to.

#2 Updated by Jesús García Crespo almost 11 years ago

  • Status changed from New to In progress

#3 Updated by Jesús García Crespo almost 11 years ago

  • Subject set to "Browse directory" feature

[g] Labels added: Type-Enhancement
[g] Labels removed: Type-Defect

#5 Updated by Evelyn McLellan over 10 years ago

  • Priority changed from High to Critical

Now when clicking ion browse an error message pops up: eg "The page at http://localhost says browsejob 8a723ec0-00e0-48e4-8bd8-2e23856550ce."

[g] Labels added: Priority-Critical
[g] Labels removed: Priority-High

#6 Updated by Jesús García Crespo over 10 years ago

  • Status changed from In progress to Verified

Fixed in r1160, r1163, ...

Also available in: Atom PDF