Feature #13537

Updated by David Juhasz 3 months ago

PHP Coding Standards Fixer (PHP-CS-Fixer) version 3 (Constitution) was released 3 May 2021 and requires several changes to no longer supports the AtoM `.php_cs` configuration for compatibility with file name. In version 3 the new version. See: configuration file name should be `.php-cs-fixer.php` (local) or `.php-cs-fixer.dist.php` (distributed) - see: "UPGRADE GUIDE FROM 2.x to 3.0":https://github.com/FriendsOfPHP/PHP-CS-Fixer/blob/3.0/UPGRADE-v3.md 3.0":https://github.com/FriendsOfPHP/PHP-CS-Fixer/blob/3.0/UPGRADE-v3.md. I think we actually want to use `.php-cs-fixer.dist.php` for a list of changes required by the upgrade. "distributed" AtoM project code (e.g. the Github repo and tarball).

Back